iOS7 and 64bit

Ken's Avatar

Ken

27 Oct, 2013 08:12 AM

Hi, just wondering when will the Core and the framework be updated for iOS7? Thanks!

  1. 1 Posted by Nicolò on 28 Oct, 2013 01:40 PM

    Nicolò's Avatar

    Hello

    You can already grab 64 bit binaries from the devel branch of the repo. I'm still fixing up some elements of the UI of the framework to match iOS7 feel.

  2. 2 Posted by Ken Lee on 28 Oct, 2013 01:47 PM

    Ken Lee's Avatar

    oh! Thanks!
    I was only looking at the Master branch.

    On 2013/10/28, at 22:40, Nicolò <[email blocked]> wrote:

  3. 3 Posted by Nick Jones on 29 Nov, 2013 06:03 PM

    Nick Jones's Avatar

    Am I missing something? I grabbed the devel branch from github but when I try to create an archive of my package for testing, I get the error below. I assumed this meant FastPDFKit didn't support ios7 and 64 bit, but then I saw this discussion.

    ld: warning: ignoring file /Users/jonesn/Documents/FastPdfKit-devel/FastPdfKit.embeddedframework/FastPdfKit.framework/FastPdfKit, missing required architecture arm64 in file /Users/jonesn/Documents/FastPdfKit-devel/FastPdfKit.embeddedframework/FastPdfKit.framework/FastPdfKit (3 slices

  4. 4 Posted by Glyclerty on 09 Dec, 2013 02:26 AM

    Glyclerty's Avatar

    8趷

  5. 5 Posted by Davide on 17 Mar, 2014 09:47 AM

    Davide's Avatar

    I'm not able to find the right framework to build with arm64 arch.
    The devel branch also seems to fail on build:

    ld: warning: ignoring file Project/External/FastPdfKit.embeddedframework/FastPdfKit.framework/FastPdfKit, missing required architecture arm64 in file Project/External/FastPdfKit.embeddedframework/FastPdfKit.framework/FastPdfKit (3 slices)
    Undefined symbols for architecture arm64:
    "_OBJC_METACLASS_$_ReaderViewController", referenced from: OBJC_METACLASS$_PDFViewController in PDFViewController.o "_OBJC_CLASS_$_MFDocumentManager", referenced from: objc-class-ref in Prodotti.o objc-class-ref in PDF.o "_OBJC_CLASS_$_ReaderViewController", referenced from: OBJC_CLASS$_PDFViewController in PDFViewController.o "_OBJC_IVAR_$_ReaderViewController.rollawayToolbar", referenced from: -[PDFViewController showToolbar] in PDFViewController.o "_OBJC_IVAR_$_ReaderViewController.toolbarHeight", referenced from: -[PDFViewController prepareToolbar] in PDFViewController.o "_OBJC_IVAR_$_ReaderViewController.pdfOpen", referenced from: -[PDFViewController actionDismiss:] in PDFViewController.o ld: symbol(s) not found for architecture arm64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

  6. 6 Posted by ronaldnu on 27 Mar, 2014 01:00 AM

    ronaldnu's Avatar

    comment_body

  7. 7 Posted by tomsego on 01 Apr, 2014 10:21 AM

    tomsego's Avatar

    comment_body

  8. 8 Posted by tomsxuy on 01 Apr, 2014 04:11 PM

    tomsxuy's Avatar

    comment_body

  9. 9 Posted by tomsfat on 02 Apr, 2014 03:36 AM

    tomsfat's Avatar

    comment_body

  10. 10 Posted by ronalmix on 02 Apr, 2014 03:43 AM

    ronalmix's Avatar

    comment_body

  11. 11 Posted by ronalnjn on 02 Apr, 2014 07:34 AM

    ronalnjn's Avatar

    comment_body

  12. 12 Posted by bryceh on 09 Apr, 2014 08:16 PM

    bryceh's Avatar

    Also having the same issue. If we make the deployment target 6.0 then it will compile correctly. The trouble is we want 7.0 as the deployment target.

  13. 13 Posted by Denis on 22 Apr, 2014 02:26 PM

    Denis's Avatar

    Hi mate,
    i compiled using the embeddedframework since 2 weeks ago, and yesterday i tried to upload my ipa trough the app store but the compiler say this all the time:
    "FastPdfKit.embeddedframework/FastPdfKit.framework/FastPdfKit' for architecture armv7s clang: error: linker command failed with exit code 1 (use -v to see invocation)"

    I try also to download the developer branch and generate a new framework but the project is also not compiling...

    what can i do? i cannot even upload the app on app store...i'm stocked.

    thanks in advance

  14. Support Staff 14 Posted by Matteo on 23 Apr, 2014 03:01 PM

    Matteo's Avatar

    Hello

    Please, can you try the current master branch on github? It does correctly include 64 bit binaries for me.

  15. 15 Posted by sviluppo on 23 Apr, 2014 03:26 PM

    sviluppo's Avatar

    This comment was split into a new private discussion: iOS7 and 64 bit ita

    Ciao matteo,
    ti va se scrivo in italiano?

    Ho provato a utilizzare la master branch qui
    https://github.com/mobfarm/fastpdfkit,ecco la mia procedura:

     1. aperto il progetto
     2. scelto il target FastPdfKit
     3. fatto un clean
     4. fatto un build
     5. poi ho preso la cartella rigenerata con enbedded framework e
        sostituita con quella esistente.

    Ancora lo stesso errore, anche facendo un clean del mio progetto.

    La stessa cosa l'ho fatta con la developer branch.
    Non sò più che pesci pigliare.
    Cosa mi consiglieresti?

    Denis Bulgarini
    Chief Developer
    Mobile +39 333 5975769

    --

    iTown LAB

    Via Murachette, 2/B, 25015 - Desenzano del Garda (BS)
    Phone +39 030 9911141
    www.itownapp.it <http://www.itownapp.it>

    --

    Il 23/04/14 17:01, Matteo ha scritto:

  16. 16 Posted by jobelle.vallega on 23 Apr, 2014 04:34 PM

    jobelle.vallega's Avatar

    Hi Matteo,
    I think the sample app can run now in ios7, but when i tried to install it on my own project using the tutorial vidoes you have, i have an error. Please i need a reply asap. Or can you direct me how to install it on my app? the videos seems old already,

    Thanks, A lot !!!

  17. Support Staff 17 Posted by Matteo on 24 Apr, 2014 07:29 AM

    Matteo's Avatar

    Hi jobelle,
    Please, can you report what is the output of the following command from terminal
    lipo - info /Users/jobellevallega/FastPdfKit/FPKCore/libFastPdfKit.a
    Thanks!

  18. 18 Posted by Alberto on 29 Apr, 2014 02:54 PM

    Alberto's Avatar

    Hi, same issue and lipo command return correctly:
    armv7 armv7s i386 x86_64 arm64

  19. 19 Posted by Alberto on 29 Apr, 2014 04:07 PM

    Alberto's Avatar

    More stability fixes. Moooooore.
    28 April 2014 release works for me.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac