How to add the framework to an existent project ?

Thomas's Avatar


13 Mar, 2018 08:48 AM

I was using the embeded framework but since it is not avaible anymore how can i use the last version avaible ?
I try to add the whole project to my application but i had signing problems with the simple app and kiosk app included.
Can you help and give a procedure ?
Thanks in advance


  1. 1 Posted by Thomas on 13 Mar, 2018 09:41 AM

    Thomas's Avatar

    I drag the project in mine , i work nice in the simulator but i got an error when running it on a ipad : Pad (2) has denied the launch request.
    What do i need to do ?

  2. Support Staff 2 Posted by Matteo on 15 Mar, 2018 04:53 PM

    Matteo's Avatar

    Hi Thomas,
    it doesn't seem that that message is related to FastPdfKit.
    It should be able to run on the simulator or on device without any issue.
    Are you able to archive the project for a generic device instead of running directly one the iPad?

  3. 3 Posted by Thomas on 16 Mar, 2018 07:07 AM

    Thomas's Avatar

    Your are right when i archive the project and install it on a ipad it doesn't lauch.
    I proceed like that :
    - I remove the reference of the emebed framework - I drag the fastpdfkit.xcodeproj in my project - i move the fastpdfkit-framework.xxconfig in my project (copy items) - In the project tab - Info - configurations : i change debug,release,ad-hoc config to Fastpdfkitframework - I add in General Tab - Linked Frameworks and libraries : fastpdfkit.framework.

    It run fine in the simulator but i cannot deploy it on an real device (even with an archive)
    I got an error when i try to lauch it with xcode about : dyld_abort with payload.

    To setup the project i had to change the bundle id and provision profile to the project by creating ones in my apple developper (simpleapp,fastpdfkit,kioskapp,extended).

    Thanks in advance for your help ;)
    ps: Will you continue to update this librairy ?

  4. Support Staff 4 Posted by Matteo on 16 Mar, 2018 07:51 AM

    Matteo's Avatar

    The xcconfig step is not necessay anymore.
    Also I’m not sure what you are doing on step 3 on the info tab. That should
    not be necessary.


  5. 5 Posted by Thomas on 16 Mar, 2018 08:18 AM

    Thomas's Avatar


    I try without the xxconfig step, when i wanted to run it on a ipad i got a similar error:
    dyld: Library not loaded : @rpath/FastPdfKit.framework/FastPdfKit
    Refererenced from :/var/containers/Bundle/Application/......
    Reason : Image not found

    ps: do i need to create bundle id and distribution profile for simpleapp,fastpdfkit,kioskapp,extended projects ?

    Thanks in advance

  6. 6 Posted by thomas on 16 Mar, 2018 08:30 AM

    thomas's Avatar

    It works ;)
    I add the framework to the embedded binaries.

    Last question : do i need to create bundle id and distribution profile for simpleapp,fastpdfkit,kioskapp,extended projects ?
    I go compilation error whitout ?

  7. Support Staff 7 Posted by Matteo on 16 Mar, 2018 08:31 AM

    Matteo's Avatar

    You just need a provisioning profile for your own target(s): main app and eventually extensions.

  8. Matteo closed this discussion on 16 Mar, 2018 08:31 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac